Jump to content
Sign in to follow this  

Just Installed Full Yosh and jet kit.

Recommended Posts

Whew, I started at 4 pm and ended at 11:30 last night, but I got all the parts back on, I did not realize how in depth that install was. I got to take a short spin, and WOW what a difference, I went with 155 and 25.

My question is I think when I took off my throttle cable I might have messed with the screws when I took it off, and now my throttle does not snap back, it there something to check the correct throttle placement.

thank you :banghead::banghead:🤣

Share this post


Link to post
Share on other sites

The return cable should be adjusted so that there is about 1/8" of thread showing above the top of the upper adjustment nut. The pulling cable should be adjusted so that there is about 1/8" of play in the throttle tube.

Share this post


Link to post
Share on other sites

i would check to see if anything was rubbing or interfearing with the cable or throttle wheel.mine is spring loaded and the wheel will snap back if i turn it by hand

Share this post


Link to post
Share on other sites

Check the angles of the metal sections of the cables that fasten to the bracket on the carb. I just worked on mine and had the same problem. Changed the positions and the binding went away. Kind of obvious if the angles are causing the binding if you take a good look at them.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...