Jump to content
Sign in to follow this  

Idling Problem

Recommended Posts

My bike stays around 4300 RPMs after I hit the throttle and wont return to normal idle. I tried adjusting the idle but no matter where I set it after I hit the throttle it stays above 4000 and only sometimes does it return to normal idle after 30 seconds or so. Thanks for any help.

Share this post


Link to post
Share on other sites

Try cleaning the carb, lubing the cables, and putting a little bit of grease in the throttle tube. and make sure your jetting is right

Share this post


Link to post
Share on other sites

first try playing with the air mixture screw, that is more than likely the problem.

Share this post


Link to post
Share on other sites

oh yeah, if that doesnt work. try the valves, just check the clearance. these kxfs are more than notorious for the valves wearing out.

Share this post


Link to post
Share on other sites
oh yeah, if that doesnt work. try the valves, just check the clearance. these kxfs are more than notorious for the valves wearing out.

If it was the valve clearances then it probably would not want to idle at all.

Share this post


Link to post
Share on other sites

The carb is clean and the cables are lubed adjusted and working fine and the valves are in spec. The jetting is good also. It has done it since it was new it will idle fine after start up until I hit the throttle. After that it idles at 4000-4300.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...