Jump to content
Sign in to follow this  

03 Yz250f

Recommended Posts

Just Wanted To Know If Anyone Can Help? I Have A O3 Yz250f And It Just Does Not Run Like It Use To. I Thought It Was The Clutch Slipping However I Had A Barnett Clutch Put In It And It Still Is Acting Like The Clutch Is Slipping. Could It Be Any Thing Else?

Share this post


Link to post
Share on other sites

It Happens In Every Gear It Really Sounds Like It Is Moving But It Pretty Much Goes The Same In Every Gear, It Does Seem Like After I Ride It For 5 Ot 10 Minutes It Gets Worse?

Share this post


Link to post
Share on other sites

Are you sure that your tire is not spinning out of control? On my friends 03 yz250f it seems like his clutch is slipping but his tire is almost bald, and it just isn't hooking up. To see if your clutch is slipping ride it on blacktop, so you know you are getting good grip. Also does your lever have play in it? It should have some but not tons.

Share this post


Link to post
Share on other sites

Brand New Tires And Same On Black Top, Lever Has Some Play, Just Do Not Know If The Mechanic That Put The New Clutch In Messed Sometning Up Or What But I Did Have Three Long Rides On The New Clutch Before It Starting Doing This, Any Idea What Else It Could Be?

Share this post


Link to post
Share on other sites

Also My Hot Start Lever Is Frozen And Will Not Budge Do You Think This Is Related?

Share this post


Link to post
Share on other sites

It shouldn't be. Get a new hot start cable though. You will thank me when you tip it over and you try to start it again.

Share this post


Link to post
Share on other sites

It sounds like your clutch needs adjusted. Take it back to the mech who installed the clutch and show him how it acts. He should be able to fix it with a simple adjustment. Don't ride it like it is, you might burn up the clutch plates.

The hot start is not related to your problem.

Share this post


Link to post
Share on other sites

could it possibly be the spark plug? the plug looks like crap.

Share this post


Link to post
Share on other sites

can anyone explain to me what it feels like when your clutch is slipping? maybe i'm not explaining it correctly

Share this post


Link to post
Share on other sites

If your clutch is slipping, you rev the engine and the bike doesn't move in proportion to the sound of the engine RPM. The engine sounds normal, but the bike moves sluggishly.

Share this post


Link to post
Share on other sites
It sounds like your clutch needs adjusted. Take it back to the mech who installed the clutch and show him how it acts. He should be able to fix it with a simple adjustment. Don't ride it like it is, you might burn up the clutch plates.

The hot start is not related to your problem.

what he said!!

check the clutch springs as well - or have your mechanic do it.

Share this post


Link to post
Share on other sites

Just a long-shot, but you (or somebody else) didn't put a different oil in it than usual did you, maybe an auto oil with "friction modifiers?" If, by chance, you did, your clutch could slip like crazy causing something similar to what you are describing..............

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...