04 WR450 Problems

dont forget to tell the remedy.......

I still haven't figured this damn thing out. Anybody else have any help??? I don't want to just start replacing stuff, but it looks like I'm going to have to.

Let me say this, I've tried testing each part individually by the Service manuals specs, and it seems to me that everything they tell you to test, comes out OK. So the only thing that you can't really test is the CDI/ECM and I don't really want to have to shell out that money if I don't have too.

This thread kind of died. SkiBumm never told us if he fixed the issue of no spark, but here's my dilemma. It's a long story, but I'll try to be brief. This also pertains to an '03 WR450.

I sheared the 6 bolts that hold the flywheel and starter clutch together. The stator was ruined and so was the flywheel due to a bolt head embedding itself in the flywheel. Bike ran very well up to the point of failure.

So I replaced the flywheel with a Trailtech +4 oz.

I replaced the stator with an ElectrexUSA stator bought from Rocky Mountain. The stator actually came with one connector that was not correct, so I spliced and soldered on the old connector.

I put the bike back together and it would not fire. I tested for spark by placing the plug against the cylinder and did not have a spark.

So, I began to troubleshoot the ignition problem as described in the manual as best I could with a multimeter. I replaced the battery, I replaced the killswitch and I replaced the ignition coil, all to no avail. Still no spark.

The light on the on/off switch is working. The two fuses are also still good, at least through visual inspection.

Can anyone point me in the right direction as to what could be happening? The next thing to replace is the CDI. I don't think I did anything wrong during the install of the flywheel or the stator. I think it'd be difficult for me to mount the pick-up backwards or anything like that.

Thanks for any advice.

This sounds like the same problem i have !

Have just replaced stator after rewinding it myself

But bike won't fire up

Is there an inline fuse etc

Did you manage to solve your problem ?


email me (geoff@trailtech.net) or call me on Monday. I will help you get you bike running. It will be easy (and free).


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now