02 YZ426F clutch issue...with video!

Hey everyone, I tore my clutch apart, and came up with the following video as to what I believe the problem is. Can anyone share their opinion? I would greatly appreciate it.

BTW: I was not able to tighten the boss, i actually ordered a whole new boss and basket because it was just a tad worn.

Thanks Jeep.


I found one of your problems; the video link isn't working. Get that sorted out first and it'll make it a bit easier. :excuseme:

Hrmm...im not sure why it isnt working... i just had my girlfriend make sure it wasnt just my computer :excuseme:

the forum is chopping the link, so i replaced it with just the text...this was done after i got 2 posts about it not working :-(

maybe someone else can verify it?

It doesn't work.

Wow...my first google video and no one can watch it.. haha so it doesnt work for me either if i click on that link in the forum, i put it back in again, and it works now..well see if anyone else can view it.


Well, whats the problem with the clutch?

Serious clutch grabbing. if i give it a lot of throttle before letting the lever out the bike makes a chirpping sound and dies. if the bike is barely moving forward and i let out the clutch in first gear it makes the chirpping noise and wants to die...in order to start moving i really gotta let the clutch out slow and give it practicaclly no gas.

Thanks for the replies!

Also: is the boss supposed to move like it does? That just seems very odd to me....

Vid works fine for me. Anyway, your clutch boss is toast! That same problem happened to my 2002 YZ426. The nut is likley torqued on there fine, but the spline inside that boss will be seperated from the whole deal. The spline of the boss is a steel insert and they have been known to break. Replace the boss and you will be rockin. Also check the gear on the back of the clutch basket.. they get loose and cause all kinds of trouble.

hah i figured it was something broken...i'll have new parts on wednesday, and the clutch pulling tool today, so i will let you guys know wed night/thursday how it worked..thanks a lot for confirming thats the problem!!


It turns out that it was just my computer that wouldn't open the link. I couldn't open up Google or ebay. I did a spyware scan, a few things got deleted and now the link works. Sorry for troubling you about the link not working.

If what you are saying is that the clutch boss cannot be tightened on the shaft, then yes, that's a major part of the grabbing issue. The same holds true for a damaged cushion unit (broken springs) that allows the basket to rotate on th eprimary gear too freely.

Dont worry about it 450...we all have computer issues :-)

Thanks everybody for the replies. I'm glad that people actually are reading my post and giving me ideas.


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now