revs don't come down after throttle close

I have a 98 YZ400 and recently it started holding the rpm after I pull the clutch in and close the throttle. I replaced the throttle cable but same issue. I have confirmed that the return cable is working properly. The problem must be within the carburetor. Maybe the spring that opens the butterfly valve? Anyone ever have a similar problem?

I had this same problem on my 250f....sometimes the idle would "hang up" and sometimes it would drop back down.

First I found out that my bike was running lean, so I bumped the main up one size and adjusted the fuel screw and idle accordingly. Worked for me.

A hanging idle is sign of a lean condition like WFO said. Adjust your fuel screw/pilot jet according to the sticky at the top of the jetting forum and you'll have that problem solved.

I would have never guessed, Thanks.

Yep, it sounds like extra air is getting in on the engine side of the carby, causing a lean mix, maybe just be a loose fitting. Does the fuel screw still have the o-ring on it(it may have fallen off if you've taken the screw out recently), or the fuel screw could have fallen out.

Oh, check the hot start as well. I like to put some grease on the plunger to help seal it and keep it working smoothly.

In case anyone is interested I finally got this problem fixed. On the top of the crab is a dual rocker arm piece that pulls the slide up. The shaft goes though this piece has a spring to keep the slide down; it is held on by a screw and a treaded stud. When I took the crab apart this little stud was floating around in there. The problem is completely gone with that stud back in place. This makes since because as the throttle was closed the slide had nothing but gravity to get it back down.

I had the same issues with a hanging idle.

Changed the throttle cables..nothing.

Checked everything over, nothing..

Then I checked the hot start plunger and that was the culprit. grit and grime had gotten into it's little hole in the carb and caused the issue.

It idles right down now and fixed the problem.


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now