Jump to content
Sign in to follow this  

front brakes still spongy

Recommended Posts

Front brakes still spongy I need some help :thumbsup: . I have a crf250x,I replaced the front pads and ever since they have been spongy. I bled the line several times...I even had a mechanic bleed them, no luck. I replaced the push rod and seals at the reservoir, no luck. I pulled the brake line down so it was level at head lite and clamped the break lever to the bars, over night to let any air escape, no luck. So I am sending this out to you GURUS for your help/suggestions.

Do the break lines ever have problems? Could it be something at the caliper?

Share this post


Link to post
Share on other sites

i have the samne problem and i swear its the line, im going to try a steal baided cable after i get some money since my engine is in the middle of a valve issue

Share this post


Link to post
Share on other sites

Our's got funky like that and I just rebuilt the front master cylinder and it is now fine...

Share this post


Link to post
Share on other sites

The SS line will help a lot. The master could definitely be causing the problem. How did you bleed the brakes. top down using the master? if so that doesn't work well.

I dont have a power bleeder or a special vacuum kit, but I take a large 200 cc syringe attach a piece of tygon tubing to it and to the bleeder, open the bleeder and draw like 4-6 reservoirs of fluid down. This will get all the air out.

The only problem with this is that air gets by the threads on the bleeder screw. Not that it enters the system, but more so makes for a longer job.

Even still a pain in the but. Next time I will spend the 35 for the vacuum kit.

Share this post


Link to post
Share on other sites

My 05 became spongey as you described, I discovered the problem, at least for me, was at the lever assembly. I just took everything apart, and cleaned it, especially at the plunger. Once back together I never noticed the problem again.

Share this post


Link to post
Share on other sites

Thanks for the replies...I did bleed it from the top. I will try from the bottom to see if it works.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×