Jump to content
Sign in to follow this  

Please Help Me Fast!!!

Recommended Posts

Alright well took the bike out to the track and filled it with oil and ran it for a few hours and ran great and then took it to his farm and before that it was just sitting in between for like 3 hrs on the way there, got to his house and tried kicking it a lot got it to fire a few times but no start. checked the oil and it was way overfull! drained all of the excess out and it still wont start, whats wrong with it! and how much should I expect a shop to do it? Thanks need help fast

Share this post


Link to post
Share on other sites

did u turn the gas off when u transported it?? If you don't u'll flood out ur carb. drain the gas out of it and then try it. If that fails roll start it. Hes on a farm and most of 'em have hills.

Share this post


Link to post
Share on other sites

not that fast, try roll starting it, if u have to roll start it repetedly then yes u have to adjust ur valves.

Share this post


Link to post
Share on other sites

I just tried and nothing I really need help if anybody has done this or knows please tell me

Share this post


Link to post
Share on other sites

check for spark?mabey a stator wire or icm wire somehow came loose on the way home,check for fuel in the carb,drain the floatboal,check the airbox make sure there are no obstructions.than check the valves.Id bet its something electrical since u had just been riding it at the track but its hard to tell with so little info.

Share this post


Link to post
Share on other sites

if your oil is over full you transmission oil is goin into the motoroil so you have a broken seal in the case somewhere stop tryin to start it or you will burn somethin up

Share this post


Link to post
Share on other sites

Did you drain both oils or just one? You may have put oil in the side you didn't drain. (yes, I've read about people doing it on here)

Share this post


Link to post
Share on other sites

He has spark since he said it popped a couple times. This sounds like you have a bad seal somewhere and your tranny oil is going into the engine side. I would drain both oils and refill them check your valves and then see if it fires. If your oil level goes high again then its time to tear the engine down and find the problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×