Jump to content
Sign in to follow this  

Need Help, 110 Problems!!!!

Recommended Posts

I was riding today pretty hard and I herd a noise come from the head/carb area and it died. Still has compression. Not as must as before. I instaled a TB 143 big bore kit 2 weeks ago. I checked the valves and everything is good. Not sure if it stuck a ring or bottom edn bearing blew. I puled the spark plug out to check the spark and it would not give off a spark when turned over with plug out and touching the head.

Please help anyone had a ignition problems or and ways to check!!!!

Share this post


Link to post
Share on other sites

It could be the coil.. They seem to have some kind of problem w/ them. try the Kitaco Super Coil. I've seen them as low as 53 bucks

"Kitaco Super-Coil. Higher intensity spark with faster recovery and response. Supplies 25% more energy than your stock unit, longer plug life as well as a hotter spark. This is the unit that is used on the inner rotor kit. IMPROVES THE LOW END PERFORMANCE AS WELL AS ELIMINATES MANY IGNITION PROBLEMS."

Hope this will help ya

Eric

598

Share this post


Link to post
Share on other sites

I found some metal in the flywheel side of case and it messed up the magnito, Im taking the engine to someone to be torn down to go through.

any body know where to fine used magnito and sfuff inside the cover

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×