Jump to content
Sign in to follow this  

new exhaust running lean pics

Recommended Posts

i just installed a full rs-3 on my stock drz400sm and the header turned purple and blue around the mount part is this bad? :thumbsup:

the exhaust is open with no insert, and i havent done the 3x3 mod or jetted.

pictures

Picture100.jpg

Picture101.jpg

Picture099.jpg

Picture098.jpg

Share this post


Link to post
Share on other sites

Thats completely normal of a stainless steel header. Mine is blue/purple/silver colored all the way to where the slipon

Share this post


Link to post
Share on other sites

thanks for the help later the week i will get the jet kit and 3x3 mod done ....

one other question i wanted to mount my exhaust on the subframe hole back from the stock mount, do u use the spacer and stuff or get a smaller both to mount it. is anybody got pics post them thanks

Share this post


Link to post
Share on other sites

I'd be more concerned about the proximity of that exposed rubber hose with no protection to the header than the header color. Lots of heat there could compromise that rubber quickly. I have heard that a a header can reach 1000 degrees F+

Share this post


Link to post
Share on other sites

This is fairly normal color for stainless. My rs3 has a slight brown color. Popping on decel could indicate a lean condition.

Share this post


Link to post
Share on other sites

just some even popping on decel is usually a sign of good jetting, now backfires are a different story

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×