Jump to content
Sign in to follow this  

426 w/ LOTS of popping on decel.

Recommended Posts

When my bike is warm, after having been ridden for a while, it pops quite a bit when I let off the throttle on decel. Should I check for exhaust leaks, fuel mixture, or jetting? Also, this is not normal popping, it does it a lot, and it is nonstop off throttle.

Share this post


Link to post
Share on other sites

fuel screw on the bottom of your carb, there's probably nothing wrong with your jets. It's called a pilot screw and if you turn it out a little bit it should be fine. My yz250f did the exact same thing, its an easy fix.

Share this post


Link to post
Share on other sites

Luckily for me, it ended up being the head pipe on the exhaust being way loose. I've only had the bike for a few weeks, and I guess the previous owner did not have any Lock-tite on the bolts, so I put some on, and tightened them up, no more popping. It was able to be moved a few inches up and down.

Share this post


Link to post
Share on other sites
Luckily for me, it ended up being the head pipe on the exhaust being way loose. I've only had the bike for a few weeks, and I guess the previous owner did not have any Lock-tite on the bolts, so I put some on, and tightened them up, no more popping. It was able to be moved a few inches up and down.

Glad you caught that. Most will say it is good practice to check the important nuts and bolts before a ride. Now you know why.

Doug

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×