Jump to content
Sign in to follow this  

50 SX bogging problem when bike gets hot

Recommended Posts

One of my friends little sister got a new 06 KTM 50 SX and when the engine gets hot and the bike bogs in the low end but once the powerband does kick in it runs fine.

If any of you guys have any suggestions on how to correct this problem please help.

Also I first thought to adjust the air/fuel mixture screw, but my friends dad was trying to tell us that there is no screw

So if you guys know if there is on or not that could help alot

Thanks in advance

Share this post


Link to post
Share on other sites

Try this:

78 main

35 pilot (stock)

40 slide

needle 2nd or 3rd clip from the top

Spark Plug BR9eix or BR10eix gapped at .022

There is an air screw.

Pump gas, not race fuel should be used.

These little bikes get stupid hot. Change the oil after every ride, use two2cool in the tranny, and teach her not to "blip" the throttle.

The other suspects are: clutch setup, and the fact that they are known for having a slight bog on the low-end with the stock carb.

Best tip: Register at KTMtalk, log-in to the KTM50 section. More info on these little bikes than can be imagined.

Share this post


Link to post
Share on other sites

Thanks it seems like you know alot about those bikes

Share this post


Link to post
Share on other sites

Yep, been there, done that, and pleased as a pig in the mud about moving up to the 65's.

It really is worth your time to check out the 50's section at KTMtalk, the knowledge there has saved me large amounts of time, money, and frustration.

Good luck, and have fun!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×