Jump to content
Sign in to follow this  

05 rmz250

Recommended Posts

a mate has a rmz250 05 and lately it has been extremely hard to start he said he has been resorted to roll starting it... does anyone know what could be happening as he wants to get it fixed but doesnt know whats wrong... also is the 05 rmz250 auto decomp?

Share this post


Link to post
Share on other sites

i had the same problem with my 05 rmz250. we took it to the shop and it turns out that the whole motor was trashed. its costing us $2,000 in US money [ i dont know if austrailia has different money ] to fix..the whole motor needs to be rebuilt and parts need to be replaced..its a mess.

Share this post


Link to post
Share on other sites

No thats not your problem. Its your valves. Your valves are out of spec and its getting harder to stat. Check your valves and reshim them and it should be fine. Ridemotox, I feel sorry for ya, the dealer ripped you off big time. Even if the motor was thrashed which I seriously doubt, I could rebuild it for around $800.

Share this post


Link to post
Share on other sites
i had the same problem with my 05 rmz250. we took it to the shop and it turns out that the whole motor was trashed. its costing us $2,000 in US money [ i dont know if austrailia has different money ] to fix..the whole motor needs to be rebuilt and parts need to be replaced..its a mess.

What the :thumbsup: I could put a stage three motor in your bike for $2000 and have a few bucks left over for some beers!!!! Sounds like I need to move to Connecticut, they are getting some good cash to work on bikes!! :ride:

I am sure the original question from this thread is a valve issue like freshout indicated. Probably tightening up. And yes there is an auto decompress on the 05'.

Share this post


Link to post
Share on other sites

I use the same procedure on my '05 KXF as I did on the '02 YZF250 which had a decomp lever. Slowly kick it just past TDC, let the kickstart come back up to the top, then give it one hard kick. Starts first time hot or cold.

Share this post


Link to post
Share on other sites

when we got my kids rmz250 new he rode it all of 5 laps and the motor smoked. They rebuilt it for free and he rode it for ahour and it smoked again. They (Suzuki) rebuilt it with me paying for labor and them for parts and now it's been fine till the cam sprocket spun.

I wonder if they put in bad cams and your cam sprockets have shifted also. They are only pressed on and not welded to the shaft. Might save you money by only changing cams or having the cams looked at or compared to new ones making sure the timing punches are correct to the lobes. That would make it harder starting

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×