Jump to content
Sign in to follow this  

Hmmm, what did I do wrong (installing new grips)

Recommended Posts

After following all the excellent TT advice, and the info from the dealer...

I am switching out the grips on our new KDX. I got the glue on, went to slide the grip onto the throttle...all is going well...get it seated (big smiles to myself) started cleaning up...SH*T!!!! I start getting splits length wise on the grip. I know someone will ask, "did you put the right grip on the right side?", I am sure I did, the grip with the slightly larger hole is the throttle...Did I over stretch it sliding it on??? I am using the same brand grips, same brand glue, that I used to install grips on mine and my daughter's bike....Big questions all around :thumbsup::ride:

Thanks in advance!!!

Share this post


Link to post
Share on other sites

Possibly you tore them when putting them on, but what kind of grips are they?

Share this post


Link to post
Share on other sites

The grips tore after you put them on? I dought they would rip even if you had them on backwards... hmmm i think this case has just been sloved.

You must have bought them from a quad rider because those grips are GAY! :thumbsup:

Share this post


Link to post
Share on other sites
... hmmm i think this case has just been sloved.

You must have bought them from a quad rider because those grips are GAY! :thumbsup:

Well i am not sure about that, but i am sure that i got your case figured out....

Your a DUMBASS :ride:

Share this post


Link to post
Share on other sites

Oh, and about your grips.... I have no clue what could have happened. I suggest getting ODI grips that require no glue. :thumbsup:

Share this post


Link to post
Share on other sites

Sounds like you got a bad set of grips, what kind and style were they?

Share this post


Link to post
Share on other sites

You probably pushed them on to the bar too far and the ends ripped :thumbsup:

Share this post


Link to post
Share on other sites

well, a good way to do it is heat them up so they can stretch without to much stress being put on them, thats what i do and i use my air compressor and it works great.

Share this post


Link to post
Share on other sites

They are Scott brand grips the clear and black ones don't have the model # :thumbsup:

Share this post


Link to post
Share on other sites

Did you put the grip on the wrong side? :thumbsup: ive done that a few times...I was wondering why it wouldnt go on easily..haha it ripped it in a few places.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×