Jump to content
Sign in to follow this  

Need help!

Recommended Posts

I took on some water this weekend :thumbsup: . I pulled the plug. I changed the oil and filter. Now the bike won't start :ride: . I have spark, compression, and fuel . Please advise.

Share this post


Link to post
Share on other sites

Did you clean out the carb?

Did you lift the bike up on the back wheel so that the water could flow out of the exhaust pipe?

Did you flip the bike upside down with the plug out so that the water could flow out?

What kind of bike is it?

Share this post


Link to post
Share on other sites

Flipped it up and drained the water and it fired right off. Last time this happened I did that right away and didn't even think about it this time. The oil was foamy when i checked it after I shut it off. Needs to be changed again.?

Share this post


Link to post
Share on other sites

Clean the carb out, ie strip it down & clean possibility that a jet is blocked.

Share this post


Link to post
Share on other sites

I changed oil and filter again and idled for a few minutes and checked oil and still foamy .

Share this post


Link to post
Share on other sites

Go buy some cheap oil, just run it through the engine, drain it, run it through, drain it, etc...you have to keep flushing it out until it clears up.

Good Luck. :thumbsup:

Share this post


Link to post
Share on other sites
Do I have to keep changing the filter?

No, as long as you're just flushing it. When it finally clears up you should though.

Share this post


Link to post
Share on other sites

barch, offtopic but geez you post alot, your profile says 15 posts a day.... thats crazy.... kinda cool that you know all that stuff.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×