Jump to content
Sign in to follow this  

400 stalling when I give it gas

Recommended Posts

I just bought a 2003 KLX400 ( I know this is in the DRZ area, but thought there would be more of you guys than KLX400 guys online) from a buddy of mine who bought it new off the showroom about 15 months ago. He rode it twice for a total of 15 miles. For the last 13 months it sat in his garage. I bought it from him cheap and put a new battery in it. It starts like a dream, but even after letting it warm up, when I twist the throttle, it bogs and stalls. I drained the gas knowing that the gas would be stale, and even ran a little carb cleaner in it. Still it stalls like it is running out of gas. While idling, it sounds perfect. I have a KTM that I have left gas in for over 4 months, and never had a problem. Any ideas?

:applause::thumbsup::ride:

Share this post


Link to post
Share on other sites

First off......you are in the right place. Plenty of people here with KLX and the green is faster too. It sounds like a clogged jet to me. I would take the jets out and clean them.

Share this post


Link to post
Share on other sites

If it was me, I'd probably go ahead and take the carb out and give it a good cleaning.

Share this post


Link to post
Share on other sites

You are going to need to pull the carb off and clean the jetting & carb. You have a plug someplace inside the carb. Not a big deal to do and there is enough info on it in this forum that you shouldn't have any problem.

Share this post


Link to post
Share on other sites

Then make sure you ask eddie about the jetting and get it set correctly :thumbsup:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×