Jump to content
Sign in to follow this  

I hate my CRF150 right now

Recommended Posts

I'll keep this as short and concise as I can. I have an 04 CRF 150 that I've been struggling to get running perfectly for the past couple months. I left it sitting over winter then tried starting it and she wouldnt fire. I drained the gas/bowl etc. The damn thing still wouldnt start, so I figured I'd up the PJ one to a 42 because it seems like most guys are doing that and it was always hard to start to begin with. With the upped PJ it will start first kick cold but when i reach mid RPMs it will start to spudder badly. I think I am somewhere around 1/4 throttle or so when it is the worst. I put the the clip on every slot on the needle and it still pops badly at around the same place. And before anyone asks; yes the air filter is clean and not over oiled. I don't know what the hell to do next :thumbsup: . Any help would be appreciated.

Share this post


Link to post
Share on other sites

Lets see you drained the gas/bowl, but did you clean the carb? some carb cleaner/air! You said the only thing you changed was the pilot to make it run, but it ran ok before you stored it im assuming, with the other pilot, so my guess is the pilot was probably plugged and maybe some other passages also, but just a guess with the info provided. Hope this was some help.

Share this post


Link to post
Share on other sites

Stock main jet, not sure what size. Nothing is modified. I had the carb off and blasted through all the passages with compressed air, so I think its fairly clean.

Share this post


Link to post
Share on other sites

That doesn't make any sense. You upped the PJ and now it's popping on decel? You must've botched up the PJ installation or something.

Edit: If you're sure your carb. is completely clean, check the screen fuel filter in your tank. This can get clogged up and starve your engine for fuel.

Share this post


Link to post
Share on other sites

Nah I didn't take the emulsion tube out. The needle slides into this tube right? Also the needle and all is still there. I previously lost the clip and had to buy a whole new needle set to replace the 2 cent clip :thumbsup:

Share this post


Link to post
Share on other sites
That doesn't make any sense. You upped the PJ and now it's popping on decel? You must've botched up the PJ installation or something.

Edit: If you're sure your carb. is completely clean, check the screen fuel filter in your tank. This can get clogged up and starve your engine for fuel.

It doesnt pop on decel it pops when I hold the throttle steady a little less than 1/4 throttle.

And where is this screen and how do I get to it?

Share this post


Link to post
Share on other sites

:ride: I noticed that my slide assembly was missing a part http://putfile.com/pic.php?pic=main/8/21817061428.jpg&s=f10

And I happened to have another one because it came with the needle i bought. But then I friggen lost it. :applause::applause::applause: Would this part effect my jetting alot?

THANK GOD I FOUND IT :thumbsup: To be honest with you I have NO IDEA how this part goes into the slide. HELP!

Share this post


Link to post
Share on other sites

The parts diagram doesn't really help either. Anyone have a good pic or explanation how it fits in the slide?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×