Jump to content
Sign in to follow this  

Top end rebuild - jammed! help please.

Recommended Posts

i'm rebuilding my 270x top end.

with the cylinder and head installed, *less* the camshaft, she turns over nicely, like a kitten, using just a hex wrench from the side.

now, after i install the cam, double check the timing, and torque down the cam towers, she won't turn over...

...when the lobes for the intake valves spin forward and down to depress the intake valves - something's jamming right there....

this has got to be something simple that i'm screwing up?

any ideas? tia!

Share this post


Link to post
Share on other sites

There will be some force when your cam reaches the valves as it is pressing them down. Tried turning with kickstarter?

Share this post


Link to post
Share on other sites

Sounds like a valve is hitting the piston. Either the piston is in backwards or the timing is not right. It could also be the cam chain in not on the lower gear, thus screwing up your timing. (yes it can pop off). Double check the piston is at TDC and the cam marks are aligned with the case. Then make sure the mark on the right where you spin the crank is aligned, and then the mark on the left side under the little access cover is aligned. If all good, maybe the piston orientation?

Is your CCT working correctly with lots of tention on the cam chain?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×