Jump to content
Sign in to follow this  

rear brake lever sticking down

Recommended Posts

Has anyone run into this......I was getting ready to load up our bikes for the weekend. I started the drz and found the brake lamp was stuck on.The rear

brake lever is sticking down,so I pulled it up and found it sticks down about every third time its pressed. I also noted a crunching type noise that seems to be coming from the rear master cylinder. It has 600 miles on it and has yet to hit the ground,so I dont think its anything damaged by me. :thumbsup:

Share this post


Link to post
Share on other sites

check the return spring. It mounts to a hole in the recess for the swingarm pivot shaft on the outside of the frame. Sounds like it is unhooked on the top and has swung down and is being crushed by the lever between the peg and lever.

Share this post


Link to post
Share on other sites

I think DRZrob has given you a good diagnosis. If that isn't it, pull the pin that attaches the linkage to the pedal and them move the pedal through its range of motion to isolate the pedal pivot from the rest of the rear brake system. That should at least lead you to the part causing the problem.

Share this post


Link to post
Share on other sites

yes, it is easy to take off and check. There is a cotter pin on the back you need to remove first but the pedal and spring will swing clear out with nothing but the bolt removed and then you can lay under the bike and get a very clear view of everything in a matter of seconds.

Share this post


Link to post
Share on other sites

Mine has been doing that for awhile I always end up having to toe it up. The spring just snapped as well so the replacement may help. I was never able to pin down the cause.

Share this post


Link to post
Share on other sites
Mine has been doing that for awhile I always end up having to toe it up. The spring just snapped as well so the replacement may help. I was never able to pin down the cause.

It must have been being pinch like robb said, otherwise I can't see it just breaking :thumbsup:

Share this post


Link to post
Share on other sites

Well I found the problem :ride: It was the rear brake lamp switch binding. I pulled the rubber boot down and lubed the switch just behind the rubber boot. :thumbsup:

Share this post


Link to post
Share on other sites

That is a seriously bound switch to overcome the pressure of the return spring.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×