Jump to content
Sign in to follow this  

04 kx250f wont start

Recommended Posts

ok..i just bought this bike for 800 and had to buy a whole new head valves..everything on th topend..(procircuit topend basiclly)i have just under 1800 in it and i got the timing spot on..or so the kawi mechanic says...but i cant get it to run...all it does is backfire everything 50 kicks...the spark looks kinda weak..could that be the problem..

IMG0114.jpg

IMG0115.jpg

IMG0117.jpg

Share this post


Link to post
Share on other sites

i had the same thing happend to mine and it turns out that the cam sproket moved half a tooth and messed it all up

Share this post


Link to post
Share on other sites

check the plate on the carb slide this can be fitted upside down and will cause this

Share this post


Link to post
Share on other sites

Re-check clearences nd double check the timing again! BTW you got an awesome deal. I bought one in the winter for 1400.

Share this post


Link to post
Share on other sites

There was a recall on the 04 models to replace the CDI unit. I would check to see if your bike is in the batch recalled.

Are you getting good fresh fuel to the motor ? Pull the carby and check that it is all fine.

I always blip the throttle once or twice a couple of minutes before I am going to start mine to get some fuel in the system., especially when the bike has not been started for a while.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×