Jump to content
Sign in to follow this  

06 wr clutch problems

Recommended Posts

I've been running in an 06 now for about 200 kilometres.Everything was running fine until yesterday when it was suddenly hard to shift down gears and even harder to find neutral.When I went to adjust the clutch I noticed the bike wanted to creep along(even up hill)with the clutch pulled right to the handlebar.I've adjusted it at both ends,free play is good,idle speed is right.I have to turn it off to put it in neutral but then it stalls as soon as i put it in gear while holding the front break on??Should I just take it back to the dealer or has anyone had a similar problem??

Share this post


Link to post
Share on other sites

if i were you and changing your oil (that includes the screen trap by your frame) than i would call up you local dealer and tell him.

Share this post


Link to post
Share on other sites

I have the same issue, but I can find neutral, so when i start it, in neutral I just give it a little gas and drop into first. For me this problem is much worce when cold, and nearly goes away when warm. I had the exact same problem on a 05 yamaha YZF 600R street bike

Share this post


Link to post
Share on other sites

They make it hard to find neutral for a specific reason. This is not a problem.

Share this post


Link to post
Share on other sites

Check Your Clutch Cable At Handle To See If It Is Comming Apart.we Have Had 3 Cables Pulling Apart At The End By The Clutch Lever. You Will Need To Take Clutch Lever Off To See If The Cable Is

Pulling Loose Or Fraying On The End.this Is What Was Causing Our

Clutch Drag.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×