Jump to content
Sign in to follow this  

2004 RMZ-250 problems help! Also need service manual

Recommended Posts

I have a 2004 rmz250 and im having some troubles with it...the top end was just rebuilt. Lets see...I start it with cold choke on and it fires up, runs nice and smooth and then you shut the choke off and it runs like crap. Wont idle, spits and sputters (well it used to, bumped up the pilot jet and that took care of the spitting, sputtering and the majority of backfiring). But it still wont idle whatsoever (yes I messed with the idle screw), also is VERY hard to start when hot. I've tried several starting methods, so I dont need any tips. I can start it when push starting.

Checked the valves with my neighbor and he said they were alright, the right exhaust valve is at 4 thousandths, other is at 5 thou and same with the intake ....both at 5. Timing is at 27th pin at TDC which I am told by the dealer is ok but to not let it go less than that. Are these valves to spec? Particularly the intakes? I cant get this thing to idle and start easier! Where should I go next????

The carb currently has a 48 pilot in it (I have everything from 40-48). And it has a 182 main, 2 sizes higher than stock. I mean...could it be dumping too much fuel in at idle speeds? Is the float possibly not shutting off? Im like out of ideas! I just looked through the threads and the valves are within spec...WHATS UP WITH MY BIIIIIIIIKE....lol...

Share this post


Link to post
Share on other sites

One change in the specs that you need to note is the torque for the cam caps, should be 87inch lbs. not 104inch lbs.

Share this post


Link to post
Share on other sites

i had the same problem...the bike not running after i put the choke on i have a 2004 kx250f...my jetting is everything is stock except my fuel screw is at 2.5 turns out a 42 pilot jet in(really helped) and a 178 main and it solved the prob

Share this post


Link to post
Share on other sites

Because sometimes it a good base to see what others are set at...Our setup although on a 298 BB kit We run a 45 pilot, 1 clip leaner on the needle and 1 jet leaner for main. 2 turns out. Was backfiring WOT so richened it 1/2 turn and runs great.

I'd start with the stock pilot and 2.5 turns out. The pilot is slow speeds and the main is mid and top end if my memory serves me correct. The stock jet for your bike should of been a 42 , 178 main, 2.5 turns out.

If it was running fine for a while and then this started maybe it's as easy as your pilot has a piece of dirt in it somehow.

Share this post


Link to post
Share on other sites

The timing chain is the 28th pin, not 27th--though I'm not sure that will solve your problem--and does anyone have a service bulletin or link to the change from 104" lbs. to 87"lbs for the cam towers?

Share this post


Link to post
Share on other sites

I never saw that bulletin :thumbsup: I just did ours at 87"lbs. and your right, there should be 12 teeth between the 2 top punches which would make it 28 because there's 8 teeth between the top and 3 oclock punch on the intake and 8 between the top and the 9 oclock puch on the exhaust thus being 28.

Share this post


Link to post
Share on other sites

Alright...when these kinds of problems arise, and you troubleshoot down to the nitty gritty like that with no success, you need to tell yourself "alright ive done everything for settings, this is going to be something really stupid". With that being said...I went to check my pilot air screw to make sure it was 2 1/8 turns out like the book says, and well what do you freaking know...the pilot screw was missing! :thumbsup: Yeah its good that its nothing major, but ya feel real stupid when you find out the problem is that a screw was missing. I have one on order from the dealer though, picking it up tomorrow and I'll let you know how it goes, I'm about 99.9999999999% positive that this will be the end of my problems though.

Share this post


Link to post
Share on other sites

RMZ 250 having running problems,runs good on choke push choke off want idle,want take gas cracks and spits,change pilot jet from 40 to 42 did not help turn air from 2.5 to 2.25,2,1.75 have change CDI box,valves check OK, timing OK check electical reading on stator OK, crankshaft sensor OK, coil OK, at witts end

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×