Jump to content
Sign in to follow this  

Throttle flat spot

Recommended Posts

Hi Guy's,

I seem to have a flat spot when I just open the throttle slightly (About an 1/8 of a turn past idle). Because it's a new bike (only 200 Km) and I'm still running it in I've only been cracking the throttle lightly during riding.

Does anybody else have the same problem?

tjdrz400e

Share this post


Link to post
Share on other sites

Take the snorkel out of your airbox. To do that take your seat off then take the snorkel out.

Share this post


Link to post
Share on other sites
Hi Guy's,

I seem to have a flat spot when I just open the throttle slightly (About an 1/8 of a turn past idle). Because it's a new bike (only 200 Km) and I'm still running it in I've only been cracking the throttle lightly during riding.

Does anybody else have the same problem?

tjdrz400e

It may not have been set up properly at the dealer.

Could just be a simple carb adjustment. Bring it back and have them take a look. I think i would wait a bit and get a few miles on it before doing any mods. :thumbsup::ride:

Share this post


Link to post
Share on other sites

I have taken the seat off and can see some sealing compound at the top of the air box opening indicating that there was some kind of fitting there which may have been a snorkel, but I suspect that the snorkel may have already been removed on the Australian models.

What are your thoughts on removing the one way water valve at the bottom of the air box as well?

Share this post


Link to post
Share on other sites

No, I wouldn''t remove the one way valve!!@! Just do the 3X3 mod by openening the air box more. Alot of mud, dirt, rocks and Water might get in if that valve is removed since it is at the Bottom of the air box. Not to mention the ocasional deep water crossings I come across, water would have gone into the air box!

Share this post


Link to post
Share on other sites

G'day tj,

Yes I have the same problem. It usually happens when I'm on and off the throttle in second gear, right at the moment when you want to lift the front wheel over something. :thumbsup: From new my dealer removed the rubber snorkel from the top of the airbox and the baffles out of the muffler. Have a look at the three bolts on the end cap of the exhaust, if one has a tack weld on it then the dealer hasnt done the exhaust. I have read on this forum about a JD jetting kit which may fix this problem. I am just living with it until I decide on an aftermaket exhaust.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×