Jump to content
Sign in to follow this  

Problems starting after rebuild?

Recommended Posts

ok so i just rebuilt my engine and it has about 2 hours run time on it and its broken in, and now to start it i have to pull it with my pickup and pop the clutch :ride: it is a 1994 cr125r :thumbsup: i put a new piston in it and v force reed valves when i rebuilt

Share this post


Link to post
Share on other sites

im thiking its the carb but im not 2 sure im trying moving the needle clip up one 2day

Share this post


Link to post
Share on other sites

What's your starting procedure? Are you giving it gas when it's cold? Is the choke on?

How's the bike run after you bump-start it? Is there excessive smoke?

And FYI, the needle will not effect how the bike start, the pilot jet and air screw will.

Share this post


Link to post
Share on other sites
What's your starting procedure? Are you giving it gas when it's cold? Is the choke on?

How's the bike run after you bump-start it? Is there excessive smoke?

And FYI, the needle will not effect how the bike start, the pilot jet and air screw will.

:thumbsup: Exactly!

Did you put a stock piston back in? Did you or someone measure the clearences of bore to piston, or ring gap?

Did you check compression? Retorque head bolts to factory specs? Is reed valve cage seated good and carb boot tight?

Check the basics before panic mode.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×