Jump to content
Sign in to follow this  

Engine Sputter at high RPM

Recommended Posts

Was riding my '03 WR250F this weekend and when I got the RPM's up fairly high in any gear the motor really started to sputter (it also did it when in neutral and holding the throttle). It has never done this before and the only thing I've done since the last ride was oil chance, air filter maintenance and greasing the steerer bearings. If you didn't get up the RPM's it ran fine. I've done the free mods, FMF exhaust and the JD Jetting kit which I put at the recommended settings and haven't touched since. Elevation and temp weren't any different than usual. I'm thinking jetting but maybe it's something simpler?

Share this post


Link to post
Share on other sites

i have had that same problem and if thats the case your on the wrong clip adjust it one at a time starting from 2nd down and one turn out and work your way through

Share this post


Link to post
Share on other sites

If it is when you are full throttle, go smaller on the main jet. You are rich.

Share this post


Link to post
Share on other sites
If it is when you are full throttle, go smaller on the main jet. You are rich.

+1 I had this problem when I first installed the jd kit. Went down 1 from 185 to 180. I bought a 182 but have never put it in to see what difference it would make but was very happy with the 180...

Share this post


Link to post
Share on other sites

I've had the jetting kit in for a couple of years now, why would it be a problem now? I don't think anything has changed. If I'm too rich could it just be a fuel/air mixture screw issue or would that be through the whole range?

Share this post


Link to post
Share on other sites
I've had the jetting kit in for a couple of years now, why would it be a problem now? I don't think anything has changed. If I'm too rich could it just be a fuel/air mixture screw issue or would that be through the whole range?

Did it sit for a while, could the carbs need cleaning, bad fuel.

If the jetting was once correct then I would start somewhere else.

Spark plug?

Share this post


Link to post
Share on other sites

I talked to someone at work today and he suggested the same things, spark plug and fuel. I'm pretty certain the fuel was good but the bike did sit a while since the last long ride. I think I'll drain the fuel and put a new plug in and see where that goes. Thanks for the help guys.

Share this post


Link to post
Share on other sites
I talked to someone at work today and he suggested the same things, spark plug and fuel. I'm pretty certain the fuel was good but the bike did sit a while since the last long ride. I think I'll drain the fuel and put a new plug in and see where that goes. Thanks for the help guys.

Get ya some carb cleaner also and since you did the jet kit you know where they are. Clean it out.

Share this post


Link to post
Share on other sites

A change in temperature is enough to change your settings.

I would do what Lasik says, and clean it out first.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×