Jump to content
Sign in to follow this  

Klr250 Help

Recommended Posts

hey i am 15 years old and have an 85 klr250 i bought it used a couple months ago and it was running fine. First of all my choke cable doesnt work so i have been tugging on it right where it goes into the carb and messing with the idle screw to get it started. Last week my friend was riding it and ended up leaving it on overnight after tearin it up on the trails. Now i can start it and everything seems fine, but when i shift to first and let off the clutch the rpms drop and the engine dies unless i pull the clutch back in and give it some gas. When i let the clutch out and try to give it gas nothing happens and the engine continues to die. I dont know what is wrong. Any suggestions would be helpful. THANKS

Share this post


Link to post
Share on other sites

You've might've messed up the idle screw, and need to lean out or richen the mix.

Alternately, it sounds like you have a dragging clutch. The clutch on an '85 is probably well-toasted, and I'll bet you haven't changed that tranny oil in a while?

YOu might have toasted your clutch. That sounds like it to me. Often, a bike will run fine while the clutch is hot, but when it cools down, it gets fiddly. Try changing the oil, warming the bike up properly, and see if it engages the clutch. YOu might also better check the clutch plates and basket. Changing the clutch plates might help, but on a bike that old, I will bet that the whole basket needs a replacement--about $300-400.

Share this post


Link to post
Share on other sites

yea bro I would start by getting a few plugs and get the carb adjusted right.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×