Jump to content
Sign in to follow this  

After lond ride my DRZ sputters....

Recommended Posts

SO I drove from Oak Ridge, TN to Nashville, TN yesterday. The new 15/38 gearing works great on the highway BTW. So, I pushed the bike pretty hard but really normal for my riding. THe only thing different is the length of the ride. About 2.5 hrs. So I rode the bike today and noticed that the bike sputters or misses when I'm accelerating. It feels like it's running out of gas and then back at it and away we go. When I hold the throttle steady like in 5th gear, it doesn't do it. And it's just on about the first 1/8 to 1/4 throttle. Any suggestions?

Share this post


Link to post
Share on other sites

Sure sounds like fuel issue, clogged jet maybe?

I would get some carb cleaner and use it double or triple strength from recommended dosage and give it a shot.

Ron W.

Share this post


Link to post
Share on other sites

It idles pretty smooth. FCR 39 carb. I'll check for water, but I never put gas in it from a bottle. Just from the pump. The first time it did it, I was pulling out from a traffic light, leaning pretty heavy to the left. It sputtered, picked up, sputtered again then went on it's way.

Share this post


Link to post
Share on other sites
they come pretty lean don't they? Eddie?

hes running a FCR conversion on a S that has the correct jetting.

his bike was running fine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×