Jump to content
Sign in to follow this  

FCR Install & Tuning ??

Recommended Posts

I'm the proud owner of a new FCR kit for my '05 DRZ-400SM, and I have it all installed per the recommendations. I took it for a couple of rides today and when hard on the gas, it's awesome! Big power gains from the stocker, just like I'd hoped.

The problem is when I'm at anywhere from idle to moderate cruising RPM's. The bike wants to sputter and die like I need to switch to reserve (I don't). I'm at 2,500 ft altitude with FMF Q pipe.

I left the jetting and fuel screw settings alone from the way the kit came, which seemed to be the recommendation for my setup. Any suggestions? :thumbsup:

Share this post


Link to post
Share on other sites

Yes. Where did you buy the kit? What style FCR is it? What jetting is in it now? It sounds lean but it is necessary to know current jetting to make recommendations. Any air leaks? How are you operating the petcock?

Share this post


Link to post
Share on other sites

I'm, also one of the new owners.... but have an '06 S with stock pipe. I installed my kit last weekend, and have exactly the same symptoms as you.... maybe not quite as bad. Mine sputters and hesitates just off idle, but is fine once it gets going. It does sound like it is burbling and needing to be switched to reserve when I'm just cruising (not accelerating). I have the FMS 01 fuel screw, and when I screw it all the way in, the bike actually idles faster??? Burned recommended that I pull the FMS fuel screw out, and replace it with the original, as sometimes the aftermarket screws aren't machined correctly. Burned also recommended going down to a smaller main jet if the fuel screw didn't work. I have the 155 jet for the stock pipe.

Any other new FCR owners with this problem that have found a fix?

Share this post


Link to post
Share on other sites

Easy fix on mine once I figured it out. The choke knob wasn't pushing in all the way because the edge of the knob was hitting the petcock. I trimmed about 1/8" off one edge of the knob, and now it can slide in all the way. Suddenly runs great with no more stuttering! Me very happy! :thumbsup:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×