Jump to content
Sign in to follow this  

Ttr 125l Idle

Recommended Posts

Have a 2005 ttr125l, it is hard to start cold, once i get started & warmed up a bit it starts easy and runs good, but I can't get this thing to idle worth a damn!

Adjusting the idle screw on the carb does not seem to effect the idle much at all. Any ideas?

Share this post


Link to post
Share on other sites

You might need to go up a size on the pilot jet. Have you done any mods to this bike? Of course, the carburetor could just need a good cleaning.

Share this post


Link to post
Share on other sites

No mods! I've taken the carb off & cleaned it out. One thing though, after I cleaned the carb it ran & idled great but then my daughter rode it for about a 1/2 hour & it started idling really fast. I adjusted the idle screw and it ran great the rest of the day! Now 4 days later NO IDLE & as I described before carb adjustment does not help.

Share this post


Link to post
Share on other sites

Sounds odd, this is probably an easy fix, I'm just not thinking clearly at the moment. Maybe you should try cleaning the carburetor out again, and see what happens. Also, after cleaning it out again, make sure you mess with the idle screw more.

Share this post


Link to post
Share on other sites

Sounds like you have a bad batch of gas that is contaminating and plugging your jets, drain and flush fuel tank, and clean the carb thoroughly and reassemble.

Share this post


Link to post
Share on other sites
Sounds like you have a bad batch of gas that is contaminating and plugging your jets, drain and flush fuel tank, and clean the carb thoroughly and reassemble.

Agreed. :thumbsup:

Dump the tank and give it a good cleaning, then reclean the carb and jets.

It probably wouldn't hurt to go up to the 17.5 pilot jet while you're in there even if you don't have any mods. The stock jet is too small.

Plus you know the new jet won't be clogged.

Share this post


Link to post
Share on other sites

dump the tank...hope it works...

You have to do it after winter also...bad gas sucks! :thumbsup:

Good luck, hope it works...also, like yamaha356 said, clean it out, maybe your float is gettin stuck also, or needle. I am not sure, just guesses, its worth tryin to fix b4 bringin it to the dealer of course and payin labor! :ride:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×