Jump to content
Sign in to follow this  

klr650 bogging down/stalling

Recommended Posts

We have two 2006 KLR 650's which we bought in January. One of the bikes intermittently bogs down and then eventually stalls while slowing down or downshifting. This bike has less than 350 miles on it and has happended about 4 times. We have taken the bike to the dealership three times with no diagnosis. They have sprayed carburetor cleaner in the carburetor, taken apart and cleaned the carburetor, and then basically told us "there is nothing wrong with the bike and they can't help us!. It usually starts running rough about 10 minutes after running. After it stalls, gas pours out of the bottom. We have asked if this is a float or needle problem, fuel line problem, or electrical problem with no answers. They only tell us they have checked everything. Any suggestions?

Share this post


Link to post
Share on other sites

Thanks for the website. They have supposedly checked the vent lines. I appreciate your help.

Thanks!

Share this post


Link to post
Share on other sites

I'm no gearhead, but I'd check that the engine isn't getting choked. When the engine is revving, the slight differences in air volume (caused by choking) getting to the cylinder are negligible, but at low, idling revs, it is a substantial difference.

The solution is a matter of simply adjusting the range of the choke lever on the handlebar.

I had this problem once and a minor adjustment solved the issue. (but make sure that the idle is at a preferred rate at the same time) Those over-trained repair jockeys may be overlooking something very simple.

Good luck

Share this post


Link to post
Share on other sites

The guys at your dealer don't seem so bright. Gas pours out when it bogs and stalls? It's the fuel level in the bowl. Either the float valve doesn't work, or there's something preventing it from closing.

Spraying carb cleaner in the carb is not how you clean a carb, especially when it's been back three times. If the bike runs OK up until it starts to bog, the rest of the carb is probably OK. Disassemble the float valve assemble entirely, clean everything, blow out the whole area with compressed air, especially blowing back up the gas line from inside the bowl. Also, replace the fuel line with brand new Honda fuel line if you have a dealer close.

A cheap way to check if this is your problem, is to put a piece of clear hose over the bowl drain nipple and run it up above the carb. Open the bowl drain, the hose will show the fuel level in the bowl.

Share this post


Link to post
Share on other sites

If it is not the float bowl then I'd make sure the carb vent is clean and not pinched. I have an '05 and when a drop of water got into the vent...........she stopped running. Kinda felt as if it ran out of fuel.

Hope this helps.

Jay

Share this post


Link to post
Share on other sites

If the carb pukes fuel out the dump tube, seems like the float valve isn't sealing.

Could be trash between the float valve and valve seat, distorted needle valve (should be resilient at its point), and/or the float linkage is sticking in the "open" position, preventing sealing when the float bowl is full of fuel.

(Another remote possibility; punctured float--loss of float buoyancy could compromise float needle valve seating.)

Disassembly, cleaning, inspection and adjustment of the carb (including float height verification, both by internal measurement and by using clear plastic hose as a "sight-glass" (per bigfatgreenbike's suggestion above) when the carb's assembled and mounted) seem in order; make sure the float valve linkage moves freely over its range without binding.

A call to Kawasaki Customer Service may be worthwhile, if none of the above helps.

Don't know if likely the problem's related to the "choke," Mesa_AZ_99KLR650, because most Keihin CV carbs use a "starting enrichment system;" when the "choke" lever is "on," the air volume to the carb is not restricted; rather, a port becomes uncovered, dumping raw fuel into the engine, enriching the mixture. The choke lever-and-cable mechanism can be checked to make sure the choke probe is fully seated and sealing the enrichment port when in the "off" position; if the probe is not absolutely straight and seated fully when "off," a too-rich mixture can cause erratic running and loss of power.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×