Jump to content
Sign in to follow this  

Problem with carb top...

Recommended Posts

My throttle wasn't snapping back, so I took apart the cable and carb top setup, but now the carb top won't go back in. It's for the BBR handlebar kit, and I am not sure where to go from here, cause if I get it in it's the wrong way, but then the throttle doesn't have any tension? Any help would be great...

Share this post


Link to post
Share on other sites

Yeah it's kind've a hard problem to explain. I had it all together right for awhile, but the throttle was sticking. So I took the slide out and now it won't go in all the way. It's facing the right way..I dunno if that helps

Share this post


Link to post
Share on other sites

The slide has a side with a line al the way down the side, and another side(duh) with a little tapered notch that rides on the throttle screw to adjust the idle. The side with the small tapered notch goes to the side with the screws(left) and unless the threads are stripped you just twist the top back on. Other than that the only thing that would stop the cable from snapping back is if you forgot the spring. I don't think you did that so I can't think of anything else.

Share this post


Link to post
Share on other sites

How does the throttle feel when the throttle valve is out of the carb? If it's still sticky, the cable may be pinched between the frame and the tank.

Share this post


Link to post
Share on other sites

When I have the slide and spring out of the carb, but connected to the throttle, everything feels normal, there is tension, and the the throttle snaps back after every twist, but then I try and put it in (the right way) and the slide doesn't just slip in all the way, there is about 2 mm of the slide showing? Any more ideas?

Share this post


Link to post
Share on other sites

Something is not right. The slide should fit very easily. Look into the throttle tube on the carburetor and make sure there isn't anything in there.

Share this post


Link to post
Share on other sites

yeh, it just isn't in there right, like said before. make sure the tab on the carb tube is placed inside the groove on the slide.

when you think it is in, twist the slide int eh tube and it will go into place.

good luck

Share this post


Link to post
Share on other sites

Yeah I just got done taking it to a friend's shop in town. He looked at it, and the piece in the carb that the slide fits onto was bent somehow (or screwed up in some way). He just fooled around with that and now the bike runs better than before, because the throttle snaps back into place. Thanks for all your help!!!! I can't wait to ride!! Later

Share this post


Link to post
Share on other sites
Yeah I just got done taking it to a friend's shop in town. He looked at it, and the piece in the carb that the slide fits onto was bent somehow (or screwed up in some way). He just fooled around with that and now the bike runs better than before, because the throttle snaps back into place. Thanks for all your help!!!! I can't wait to ride!! Later

Sounds like the needle was not going into the centre of the needle jet when you tried to put the throttle valve in.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×