Jump to content
Sign in to follow this  

Should I Worry Or Not?

Recommended Posts

today i took off the left side cover and i found a piece of metal laying in the bottom.it turns out it broke off of that notch that holds the cam chain guide.only about half of it is gone.theres probably over a quarter inch left.it looks like plenty to hold it in cus it cant move up or down.what would cause this,i know i didnt break it.

Share this post


Link to post
Share on other sites

typically the timing chain would have to try to jump to break that tab off. Check, or better yet, replace your timing chain adjuster and check your timing...

why did you have the cover off?

Share this post


Link to post
Share on other sites

I've heard of this happening before. Other guys didn't know why it happened either. Seems strange.

Share this post


Link to post
Share on other sites

I had the same thing happen, only it was my fault, while performing a top-end rebuild I had difficulty getting the timing chain back onto the lower sprocket, I did not know what the bind was and tried to force the engine to move with the kickstarter, when I realized the timing chain had bound up at the lower sprocket I removed the side cover only to discover the small piece of aluminum broken off (it was broken because the plastic chain guide was removed during this period and the chain wadded up in the gap) any way I cleaned out the alum debris and put it back together and did an oil/filter change after a short break in ride and everything seems to be fine (been running it like that for 6 months now) Hope this helps, and I learned a valuable lesson for top end replacement....keep that timing chain supported on the lower sprocket at all times :thumbsup:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×