Jump to content
Sign in to follow this  

Bike sputters after wot backoff

Recommended Posts

xr250l dual sport........ I've been trying to dial my jetting in for a few months now, since I've done a lot of breathing mods to my bike. My oil temps get high when cruising at high speeds, so richened my needle. But even before I did this, when I run it at WOT and then back off the throttle quickly, it sputters for a second. Does his mean too rich? I've done a dozen jetting runs through the gears at WOT, and I'm having trouble reading my plug. One side of the insulator is white, and the other has black on it. The electrode is white, and the threads are black. If my main is too rich, will I get a very noticable bog? Do you need a new plug to do a jetting run correctly? Every time? (it was a new plug) -Thanks

Share this post


Link to post
Share on other sites

Sputtering usually means lean, which would make sense with the breathing mods you did.

I don't think you're reading your plug right. You want to look way down at the base of the threads. You might want to sacrifice the plug and chop the threads off altogether to get a real good look at the mixture ring.

Share this post


Link to post
Share on other sites

I'll sacrifice a plug.... should I use a new one? BTW, the reason I suspected rich was I thought it could sputter due to fuel loading during a hard long WOT run.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×