Jump to content
Sign in to follow this  

carb setup question...

Recommended Posts

...sent my carb to Jesse last week while I was on vacation to put in a new main, extended fuel screw and drill the hole in the slide. Before you guys start beating up on me, my free time is very limited and I'd rather ride than wrench.

I got it all back together today and the bike won't idle and runs like it's wayyy too rich. It's bogging until you get it to midrange at wide open throttle and then it finally goes. It doesn't feel any stronger than stock.

For reference. It's a 155 main, K&N with pre-filter and I cut the top of the airbox off.

I believe it's all hooked up correctly with the tank vent line going into nipple on the black cap of the carb and the fuel drain line going down near the shock.

Obviously, I'm going to call Jesse but it's only 6:45am his time so I thought I'd pick the collective brain trust here to see if it's something obvious or simple.

Thanks,

Mike O.

Share this post


Link to post
Share on other sites

By me description, Jesse says the float is stuck. Two choices. Take the carb out and take the bowl off, check and reassemble. Or, turn it on prime and tap the carb on the side with the plastic handle of a screwdriver a few times.

Solution #2 worked like a charm.

Bike runs like a raped ape now.

Thanks Jesse.

Mike O.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×