Jump to content
Sign in to follow this  

xr400 engine revs??

Recommended Posts

just got my xr400 on the road yesterday (motard) got it 3 weeks ago, i noticed when i open the throttle really quick the engine seems to rattle/shake very high then the power kicks in and off i go. if i open up the throttle smoothly this doesnt happen. any comments?

Share this post


Link to post
Share on other sites

actually that could b it. does that mean im too lean? im using 92 octane. one time it back fired when i let go of the throttle on full. it feels that some thing is reasonating in the engine. it last a couple of sec then the power kicks in the the rev go up normal

Share this post


Link to post
Share on other sites

The engine will not respond to that kind of quick throttle input from the stock CV carb. Nature of the beast.

If you're going to keep it as a Supermotard, I'd suggest putting a Mikuni pumper on it.

Share this post


Link to post
Share on other sites

thx guys but is there anything i can do for the pigging?? i have the needle in stock position should i raise it up a notch?

Share this post


Link to post
Share on other sites

You might have gotten some bad/cheap gas or more than 10 percent ethanol. Try some octane booster and see if it clears up. Pinging is usually a sign of low octane fuel. Have you done any motor nodifications that would raise the compression?

Share this post


Link to post
Share on other sites

no only changed the main and pilot jets, engine is stock from what i know.

Share this post


Link to post
Share on other sites

just ordered a socket to fit the tight space on the engine head so i havent checked the plug yet. I just fiinished adjusting my valves and now she starts very easy. my valves were way out could this be a reason for causing pinging?? i havent taken it out on the road yet.

Share this post


Link to post
Share on other sites

ok i asked around and heard i might b running rich so i changed my main jet back to stock 142 from 160 and that fixed it!! well actually i think im gonna try a 150 or 145 and c how they run. im might b running lean now but when she revs high and a let go of the throttle she back fires a bit. I still gotta grind my header welds so that will change things also.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×