Jump to content
Sign in to follow this  

Overheated

Recommended Posts

I have a 03 YZ125 that i rode today at open track. I pulled off and it smelled hot so when it cooled i looked in the radiator and saw there was no coolant. It leaked all over the front of the motor and i dont think any went out the overflow tube. It looks like it leaked out the seam where the right side case half meets the case cover. :thumbsup: But im not sure thats where its leaking from. I can do major motor work but i dont really want to.

Share this post


Link to post
Share on other sites
Maybe one of the rubber tubes are broken/coming off?

That's what I was thinking. Check out the hoses first. Hopefully it'll be an easy fix.

Share this post


Link to post
Share on other sites

My friend thinks it might be the water pump seal. I just wanted to see what you guys think before i tear into it since i mostly work on air cooled engines.

Share this post


Link to post
Share on other sites

If you can't find the leak then it could be a bad head gasket. :thumbsup:

Share this post


Link to post
Share on other sites
My friend thinks it might be the water pump seal. I just wanted to see what you guys think before i tear into it since i mostly work on air cooled engines.

Your oil would come out milky, if that was the case.

Share this post


Link to post
Share on other sites

Its not too bad, only the base gasket. Its time for a new topend anyways.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×