Jump to content
Sign in to follow this  

hard shifting under load.....common?

Recommended Posts

I have a 06 DRZ-s, stock as is show room floor new, 2200mi.

The bike will not shift from 1st to 2nd under a heavy, mid-full throttle load at high rpm. Is this common? will a diffrent tranny fluid help this problem?

I can pop the bike up in 1st w/ a full throttle punch from about 10-18mph, but it will not shift into 2nd so I can keep my wheelie going.

Any thoughts/ideas?

Share this post


Link to post
Share on other sites

ive got 1600mi on mine...and i havent had that proble at all.

maybe a lemon?

Share this post


Link to post
Share on other sites

I noticed my shifting got alot smoother when I switched to full Synthetic :thumbsup:

Share this post


Link to post
Share on other sites

don't shift under load - throttle off slightly.

Share this post


Link to post
Share on other sites

I have the same problem. Slip the clutch in 2nd, wheelie , let off throtle a little and try to sneek it into third .Sometimes its hard. This is the first bike I've had this problem . I will say though that i'm getting used to it now . I guess i let off a little bit more now.Just starting to get up to 5th gear now. Hang in there it gets better. :thumbsup:

Share this post


Link to post
Share on other sites

hm.....ok. I havent ridden a 4st in about 16 years.....I've been on 2st MX bikes and they shift under power, WFO all the time....this one doesnt......so i guess i'll work on letting up slightly then punching it back on, and i'll try to slightly slip the clutch during my upshifts. Thanks guys.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×