Jump to content
Sign in to follow this  

06, rear suspension clicking noise?

Recommended Posts

Hey guys, i was trying to get in some hours on the bike this evening on my backyard track and i literally just got off the bike. I was testing some different settings with the clickers on the rear shock, and i noticed that when i pushed the rear end down, there is this clicking noise now, i am pretty certain it wasn't there before. I also notice the same noise when i pull the rear end back up. I bottomed out fairly hard on a jump earlier but i am hoping i didn't break something now, any advice on where i should be checking? thanks in advance.

Share this post


Link to post
Share on other sites

Anyone has any advice for me? I checked my subframe bolts and they seem tight. Not sure what else it could be.

Share this post


Link to post
Share on other sites

Check for cracks in the subframe, plastic, seat, silencer, etc., it may not be your shock... :thumbsup:

Share this post


Link to post
Share on other sites

You've got some slack in the rear suspension. Check that the shock is in tight. Have someone lift/lower the swingarm while you inspect. You should see the movement come from somewhere. I'll probably be at either end the shock (top or bottom), could be the linkage or (less likely) the swingarm.

Good luck and keep us posted.

Share this post


Link to post
Share on other sites

You can har the noise within a certain range of the movement, for example when i push the rear end down with my hands it makes the sound at about halfway, then it goes away after it has passed that position, then coming back up once it gets to that same position the clicking or cracking noise will be heard again. I will check all the bolts and see what heppens.

Share this post


Link to post
Share on other sites

Did you hit your linkage on something? Could it be binding part way through the stroke?

Share this post


Link to post
Share on other sites

I fixed the problem, with one person pushing the suspension down, and one person actually touching the shock spring, we could feel the noise coming from the spring. We sprayed some good old WD40 around the shock area and the noise is gone, thanks for the help guys.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×