Jump to content
Sign in to follow this  

drilled slide, now runs bad

Recommended Posts

i have a 96 dr650 (suppertrape with 7 disc, top cut out of air box, k+n filter, dynojet kit 170 main) it seems many dr650 run good with a 160 main, but mine would not take full throttle unless you opened it slowly or it would sputter. 170 main works great. my brother had a 1999 dr650 and his carb was not the same? i decided to drill the extra hole in carb slide. 1st ride it felt like the 160 main was back in. open the throttle to quick and it would kick and stumble. when fully hot it seemed better. it was only 43 degrees. i put epoxy in the hole and i will test it as soon as it stops raining (unless it turns to snow). anyone have the same experiance? also i checked carb vent and flote level.

Share this post


Link to post
Share on other sites

Nope, should not affect running at all just how fast the slide falls after opening. Do you have dj needle or stock?

Share this post


Link to post
Share on other sites

Double check that the needle isn't getting hung up by going down on an angle, mine did that and ran like you describe. Once I straightened it the bike ran great. The diaphram gets twisted easily too.

Share this post


Link to post
Share on other sites

well i just got back from my first ride after i put epoxy in the extra slide hole. bike ran great no coughting or sputtering, same temp (low 40s). my bike runs better with one hole (stock) in slide. to much air to fast?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×