Jump to content
Sign in to follow this  

Bog off idle

Recommended Posts

Hi all, currently i have this bog off idle and it only happens when the engine is very hot. Everytime i upshift, and open the throttle slightly from 0-1/8 the flat spot kicks in. It does not happen if i open the throttle more. Any help is appreciated. TIA!

here's my setup

DRZ400SM - sea level, High humidity, hot weather

TT FCRMX with JD Blue needle at 3rd clip

45 pilot, 162 Main, 2 turns air fuel mixture, slow jet removed

4X3 Airbox mod with KNN hi flo air filter

uncorked full exhaust system

Share this post


Link to post
Share on other sites
got to the red needle clip 4.

Hi Eddie, red needle 4th clip was what i was using before switching to blue but i had lots of excessive popping on decel. I'm gonna use some of that chamber seal i bought from TT to seal the header pipe and mid pipe joints and try red needle again and report back if there's any improvement. While i'm at it, i'm gonna use duct tape to close up the 4X3 back to 3x3 too. Do you think an inch more on the airbox coupled with my hi flo K&N mightbe the cause of excessive popping on decel. I don't get this much with the blue needle but the bog off idle really annoys me.

Thanks!

Jim:banghead:

Share this post


Link to post
Share on other sites

main jet and needle and intake hole have no effect on decel pop.

does your bike have the PAIR valve setup?is it a EURO,UK or AU model?

Share this post


Link to post
Share on other sites
main jet and needle and intake hole have no effect on decel pop.

does your bike have the PAIR valve setup?is it a EURO,UK or AU model?

Hi Eddie, the pair system was taken out of my bike more than a yr ago and the hole bolted and sealed with a custom made aluminium piece. What else could be the problem? :lol:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×