Jump to content
Sign in to follow this  

Why wont it move?

Recommended Posts

Recently the rear brake line got burned and leaked from the exhaust on my 250F. Well I have now put on the new brake line, added fluid and the thing still spins freely when I push down the lever (which has no feeling to it anyways).

Also, on my front end. I carelessly bled the brakes completely wrong, I opened up the 8mm nut by the disk, then squeezed the lever and let it free, then tightened it back up. As of now, the front tire is always breaking, it is very hard to push (the brakes are engaging) and the lever has only a small amount of space to break because it is so loose.

Yes both brakes arent working, but dont worry it's winter in Canada and Im not riding right now.

Thanks alot in advance, I know someone will know what to do.

Share this post


Link to post
Share on other sites

Be sure that you got all of the air out of the system. Even a little bit will make the brakes spongy. Are you sure the pads aren't moving at all?

Share this post


Link to post
Share on other sites

On the rear, the pads dont move at all. On the front, they move, but it feels as though the brakes are always engaged and it is really hard to move the bike around. You can press in the front brake to make it stop a little more, but it wont lock right up.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×