Jump to content
Sign in to follow this  

losing coolant!

Recommended Posts

Past few rides I've noticed I'm low on coolant everytime before i ride. It takes about a cup of coolant to top her off. Then I noticed a bunch of coolant on my engine, frame, and skid plate. Looks like its coming out right under the pump cover, but not sure, dont see and cracks or nothing. Havn't pulled the cover yet, thought I'd ask here first.

Share this post


Link to post
Share on other sites

if it's coming out of the weep hole at the bottom of the cover it's probably the outer water pump seal, not a big deal (common)

Share this post


Link to post
Share on other sites

Ditto. Just changed mine. If the bike is fairly new you can probably get away with just changing the seal. If its a little older you will probably want to go ahead and replace most of the parts inside there. Do a search for "water pump seal" and you should find the information you need.

Share this post


Link to post
Share on other sites

# 9 i believe is the one you need. be sure and inspect the shaft for wear,also i believe the impeller is reverse thread. good luck

Share this post


Link to post
Share on other sites

oh wow, didn't even see the weep hole. looks like thats it, I'm gonna check the seal a little later, I'll let ya know how it looks. thanks.

Share this post


Link to post
Share on other sites

oh yea, bikes farely new, bought about six months ago, still on the original tires. Its on its 4th right now.

Share this post


Link to post
Share on other sites
oh yea, bikes farely new, bought about six months ago, still on the original tires. Its on its 4th right now.

On it's fourth seal? That seems excessive in 6 months.

Share this post


Link to post
Share on other sites

Damn, it's gonna cost $70 for impeller, shaft, and seal. I might try the $5 seal first.

Share this post


Link to post
Share on other sites
On it's fourth seal? That seems excessive in 6 months.

no, back 4th tire, meaning its relatively new

Share this post


Link to post
Share on other sites

Im having a coolant loss problem on my 05-450. I have changed the seal 4 times and it still leaks after one race. I have decided to change all the parts(seals/shaft/bearings...) Do I really need to change the impeller? I drilled a hole in my 05 impeller.

Share this post


Link to post
Share on other sites
Im having a coolant loss problem on my 05-450. I have changed the seal 4 times and it still leaks after one race. I have decided to change all the parts(seals/shaft/bearings...) Do I really need to change the impeller? I drilled a hole in my 05 impeller.

I believe the only difference with the newer impeller is the hole, which you have already taken care of.

Share this post


Link to post
Share on other sites

if its coming out of your overflow when you rev up the bike it could be your head gasket it happened to my friends yz250f

This is a good point, also Boysen has a real good pump and cover kit the impeller flows way better than stock.

Share this post


Link to post
Share on other sites
I drilled a hole in my 05 impeller.

what mod is this and how do you do it. i just ordered everything but the impeller and want to possible do this if it helps?

Share this post


Link to post
Share on other sites

Search this forum and you can find the link--its a 1/8" hole--3/8" from the edge

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×