Jump to content
Sign in to follow this  

Drz400sm jetting revisited

Recommended Posts

Hey guys, I ve read alot of the threads on jetting the SM, i have the full Yosh, 3x3 mod, and jet kit . I ve bumped up the pilot jet 2 sizes, messed with the air screw, changed the main and still have Popping on Deceleration. Any of you guys have any other ideas? I ve also moved the clip position several times.....HELP PLEASE:cry: LOL

Share this post


Link to post
Share on other sites
a slight pop on decel is normal.

Eddie its a constant pop, pops all the way down the rev range until just above idle..It sounds pretty bad...

Share this post


Link to post
Share on other sites
vacuum line connected to the petcock?

I ll check, just to make sure where does the other end of the vacuum line connect too. I think i remember it might have been disconnected from the other end

Share this post


Link to post
Share on other sites
Hey guys, I ve read alot of the threads on jetting the SM, i have the full Yosh, 3x3 mod, and jet kit . I ve bumped up the pilot jet 2 sizes, messed with the air screw, changed the main and still have Popping on Deceleration. Any of you guys have any other ideas? I ve also moved the clip position several times.....HELP PLEASE:cry: LOL

So what is your current jetting then and what jet kit did you use?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×