Jump to content
Sign in to follow this  

Wr250 oil leak from stator weep hole?

Recommended Posts

Just came back from a 40 mile trail ride on my 04 wr250 and noticed a bit of oil leaking from what appears to be a weep hole in the stator cover.

What might cause that, and is it an easy fix?

I have my first enduro in 3 weeks.

Thanks

Share this post


Link to post
Share on other sites

Sounds like a bad seal. I guess it's a good thing you didn't seal the weep hole, as recommended to waterproof the ignition. Pull the cover and double check the amount of oil leaking. You should be able to pull the flywheel(need a puller), pull the ignition(mark it's location carefully), pry out the seal(drain oil or put bike on side), inspect the shaft and install new seal and as Haynes loves to say "reverse the order of disassembly"

Norman

Share this post


Link to post
Share on other sites

Thanks Norman.

I pulled the cover and noticed a small puddle of premix in the bottom...just enough to leak out the weep hole a bit.

I also noticed a tiny bit of play on the stator rotor. The bike is not making any rattling noise and seems to run fine except for a small lean spot in the upper midrange I need to jet out after I installed the 4.0 slide in place of the 3.0

I'm having a friend put a seal on it and I'll see what happens.

I just don't want to loose the bearings during my fist enduro of the eason in two weeks.

Is a tiny bit of bottom end play normal? My friend says he's built new motors that seem to have the same kind of play.

Whatd'ya think?

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×