Jump to content
Sign in to follow this  

2001 503 vor enduro

Recommended Posts

i bought this bike used with low hours and first thing i did was broke the kick starter so im learning the bike slowly, the main jet that came with the bike is a 190 5 over stock i live at sea level and assume that the previous owner changed it .well the things been givin me problems ever since. the bike shop owner said vors eat up electric parts and my problem was the stator but im sure it mustr be the carb. the bike runs great at low rpm but if i get on it it misses real bad the plug is black like its running rich so i was thinking of droping the jet size down to 180 also the air filter lube could b e a factor i think.anybody have any suggestions?

Share this post


Link to post
Share on other sites

based upon my experience, it will be the stator or coil. I Had exactly the same symptoms with my 450mx. new 'berg coil fixed it.

Share this post


Link to post
Share on other sites

Hey,

You could try talking to problemsolver, I think he was having a similar issue. My nephew has a 2000 MX503 and it is the meanest, rudest, baddest bike I've ever ridden. It has aftermaket exhaust and a power valve and that's it. top of 2nd 3rd result in wheelies every time. Awesome. I hope my 450 will be close with similar improvements.

Don't give up. VORs rock!

E.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×