Jump to content
Sign in to follow this  

XR100 Jets

Recommended Posts

I have a 2001 Xr100 with an exhaust tip on it and it back fires alot when i down shift. i was wondering if its running to lean. and where can i buys jets for it at? im also looking for a new air fliter and i was wondering if anybody had any suggestion on wich is the best

Share this post


Link to post
Share on other sites

What tipe of riding do you do?Then I can give you a reccomendation on a filter.As far as jetting,what is your elevation?,and yes it is running lean.

Share this post


Link to post
Share on other sites

im not real sure of the elevation but i do mostly trail riding and race some at bbdr the local dirt drags but i really like the Twin Air fliters for their price are they any good?

Thanks, Josh

Share this post


Link to post
Share on other sites

Ok then where do you live?Twinair's are good,but my favorite is K&N because they last for the life of the bike.

Share this post


Link to post
Share on other sites

im 14. im considering on buying the K&N i just dont want to spend that much on the filter. i cant find any where that sells jets for it. i live in PA

Share this post


Link to post
Share on other sites

The stock main jet is a 95 and the pilot is a 38. It is a keihin carb so just look up keihin carb parts on ebay or go to your local shop. They should have nearly every size you want.

Share this post


Link to post
Share on other sites

Actually in 2001, the main was a 98 and the pilot was a 35. 2000's and down had the 95 main.

Share this post


Link to post
Share on other sites

Get a 100 main and a 102. Try both. You could also have an exhaust leak. Get a new exhaust gasket. They are cheap. Also, download google.earth and find out your elevation.

Share this post


Link to post
Share on other sites

I have an 03 XR100 running at around 600'. I removed the screen from the air filter holder, installed a uni, put in 5 1" air box vents, and installed a pit king exhaust tip in lieu of the stock spark arestor. Before I did this I had the same problem with backfiring when letting off the throttle. My stock jets were 35 pilot and 98 main. I started with a 38 pilot, 100 main, and the clip second from the bottom. It still had a bit of a sputter right when I up-shifted. At first I thought is was running rich so I moved the clip to the middle and it got a little worse. I did a plug chop test and the plug was white. I put the clip back to 2nd from the bottom and put in a 102 main and now it runs like a champ. Good Luck.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×