Jump to content
Sign in to follow this  

Metal Chunks in Oil!!!

Recommended Posts

I replaced my clutch today after ripping a aluminum friction plate apart this weekend. I was told by a fellow TT member that the same thing happened to him and he said to replace the clutch and keep running oil through the trans until everything has flowed out. (I am of course starting the bike and riding it for 5-10 mins before dropping the oil.

There is peices of aluminum flowing out every once and a while; as expected. However how many times to you think I should do this? is it even worth it should I just crack the case and manually take every peice out myself? (Or to the shop)

Do you think the aluminum peices can ruin the gears and/or other componets???

Thanks a lot

Here is a pic of what the ripped up plate looked like.

clutch.jpg

Share this post


Link to post
Share on other sites

I'd say you got your moneys worth.Flush a few times.Fresh oil,short ride 5 minute easy rides flush repeat till it comes clean.

Share this post


Link to post
Share on other sites

Chunks?pieces? Why don't you price a new tranny.............and then decide for yourself if its worth that risk. Gettig a "chunk" in the wrong place can take out the entier tranny and sometimes even split/crack the cases.

Share this post


Link to post
Share on other sites

I pulled the engine last night and will start ripping it apart later today, I'll try and remember to post some pics and let you know what I find.

Share this post


Link to post
Share on other sites

Time to split the cases and clean it out .. holy crap man .. how long were those suckers in there?

I would not run that bike at all until it is cleaned out FOR SURE.

Share this post


Link to post
Share on other sites

i gave the engine to my buddy who is a mechanic at a bike shop, he split the case cleaned it out, and i baught new gaskets...waiting on new bearings and I should be riding by next week! i just baught the bike like 3 weeks ago from a guy that said he had it for 3 years and only rode it for 6 months of that time. I am assuming the plates were stock and original because they were still aluminum, and no one around here uses those, the trails rip them apart.

i had the magnet drain plug for my old bike. too bad i forgot to pocket it before it was sold. ill have to order another off motosport. thanks for the ideas and feedback. wish me luck!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×