Jump to content
Sign in to follow this  

Scotts Damper mounts

Recommended Posts

I've got an 05 RMZ250 and my Scotts damper mounts keep vibrating loose. I've had several bikes with Scotts dampers and I've never had this problem. I think the issue is that there is very little area for the damper frame mount to fit onto the top of the steering tube due to the welds coming almost to the top of the tube. I'm thinking about either trying to put red threadlock or a small amount of JBWeld in there to see if either one will keep the damper from vibrating and slipping.

Has anyone else had this problem and any suggestions would be appreciated.

Thanks,

JCW

Share this post


Link to post
Share on other sites

I'll definitely use blue loctite on the bolts. I was referring to the area around the steering head tube where the damper mount goes. It's about 1/4th the surface area as most other Scotts mounts due to the welds being so high on the steering head tube. I think it's almost trying to slip off as soon as you put it on. Until the bond between the tube and the mount is strengthened, I don't think the little bolts that tighten the mount will ever work for very long.

I don't see why I would ever want to take it off, so I may scuff it up so a small amount of JBweld or something like that can be used to help bond the 2 pieces together. Otherwise, it's going to keep coming loose. I may need to go to the mount over the front fender???

Looks like I'm about the only one to use a Scotts damper on an RMZ.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×