Jump to content
Sign in to follow this  

Oil pump???

Recommended Posts

How is the oil pump issue? Is anybody still having the same problems with the later serial numbers?

Share this post


Link to post
Share on other sites

mine went out at 11.2hrs now that kaw redid the whole motor everything has been great now I have 20hrs on it and A-OK great bike and great company to work with .

Share this post


Link to post
Share on other sites

Woa, whats wrong with the 07 450? I havent even broken mine in yet, so the sooner i know whats wrong, the better. In what bikes did the issue take place?

Share this post


Link to post
Share on other sites

I don't neccesarily think the oil pump is a common issue. Thats the only case I have heard of it and didnt it have something to do with the oil pump screen?

Share this post


Link to post
Share on other sites

how often do u guys clean/replace the oil screen? just wondering...ichange it after break in....and probably right b4 every season.....but i just bought a new 07 250f...so i haven't replaced it yet

Share this post


Link to post
Share on other sites

I pulled out & cleaned my pickup screen when I 1st bought my 06 kx450f, it had quite alot of silicone from factory aswell. I've been cleaning mine every 2nd service(8hrs), & it picked up a little more, but eventualy cleaned everything out.

Share this post


Link to post
Share on other sites

Buddy of mine has an 07 450 .. . and the oil pump shaft broke apart..

If anyone has found this issue ... bring it to Kawi's attention.

Share this post


Link to post
Share on other sites
Buddy of mine has an 07 450 .. . and the oil pump shaft broke apart..

If anyone has found this issue ... bring it to Kawi's attention.

Did he put it back in wrong?

I think the oil screen isn't mentioned in the owners manual because the chances of putting the pump shaft back in wrong is high and if it's done wrong the pump wont work, killing the motor eventually.

Share this post


Link to post
Share on other sites
Did he put it back in wrong?

I think the oil screen isn't mentioned in the owners manual because the chances of putting the pump shaft back in wrong is high and if it's done wrong the pump wont work, killing the motor eventually.

Well .. . Im pretty sure he knows what he's doing ... but the shaft broke on the right side of the pump ... from what I saw the screen cleaning process would have not been close to the pump shaft.

Share this post


Link to post
Share on other sites

The pump shaft will more than likely pull out when you remove the cover.

I did this late one night when I was really tired and the pin that keys into the inner portion of the pump slipped out. I slapped it back together and now I have to figure out how to fix what I have done. I smashed the pin into the nice machined surface that the pump rides on and dented it.

If anyone has any ideas on how to fix this I would appreciate your input.

Share this post


Link to post
Share on other sites

How do you know, other than the motor blowing up, that your pump has gone bad? What's the signs?

Share this post


Link to post
Share on other sites

I have a question for this as well.. I cleaned my sceen and put everything back togather with no big issues then filled the oil and started the bike I put my head down by the cover just to listen and noticed some air coming out of the crankcase breather tube is this normal? I have never been down around that tube when the motor is running so may not have noticed before on my other bike but is there always pressure coming form the tube? no oil just air?

Share this post


Link to post
Share on other sites
I have a question for this as well.. I cleaned my sceen and put everything back togather with no big issues then filled the oil and started the bike I put my head down by the cover just to listen and noticed some air coming out of the crankcase breather tube is this normal? I have never been down around that tube when the motor is running so may not have noticed before on my other bike but is there always pressure coming form the tube? no oil just air?

Air is normal. Not like high pressure air but you should be able to feel it. If oil comes with it it's either over-serviced on oil (too much) or the scavenge pump isn't working. :)

Share this post


Link to post
Share on other sites

My o7 kx 250f has over 30hrs , my mates 60 + , neither of us touched it , my kx 450f has 25 hrs on it , not touched it no problems here , in fact we are both impressed how reliable these bikes are! just because a couple of people out of thousands have problems doesnt mean everyone will ! every product in the world have a few , made friday arvo 's .

Share this post


Link to post
Share on other sites
My o7 kx 250f has over 30hrs , my mates 60 + , neither of us touched it , my kx 450f has 25 hrs on it , not touched it no problems here , in fact we are both impressed how reliable these bikes are! just because a couple of people out of thousands have problems doesnt mean everyone will ! every product in the world have a few , made friday arvo 's .

Does oil blow out the breather tube on either bike?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×