Jump to content
Sign in to follow this  

blinkers ??

Recommended Posts

Ok I have a 06 drz400s went offroading in the mud. fell a few times but had a blast.... Today I noticed the left blinker doesnt flash, and the right only flashes sometimes... Im thinking its the switch or the relay ... Anyone have a simular situation ????? Thanks guys

:applause:

Share this post


Link to post
Share on other sites

I suggest unplugging and plugging back in all the connections first. Because one side flashes sometimes, I would think the relay is ok. I would also unplug and plug back in the bar switch for the blinkers.

It is possible a filament broke but I doubt it.

Share this post


Link to post
Share on other sites

You said you fell in the mud? I would remove the blinker covers and check for mud/water inside the blinker. I has been said if the load on the flasher is to light it might not flash. If mud/water got into a blinker causing a short the bulb may still light but the blinker might not flash. Otherwise you may have an intermittently bad flasher.

Share this post


Link to post
Share on other sites

yeah both front and rear left side doest blink.. The right side blinks but not all the time.... I was thinking maybe the switch is bad from a crash, the filemennts may not be touching when switched on (in the switch)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×